You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sys-apps/ipmiutil/files/ipmiutil-3.1.7-flags.patch

21 lines
708 B

--- ipmiutil-3.1.7/configure.ac
+++ ipmiutil-3.1.7/configure.ac
@@ -170,7 +170,7 @@
LANPLUS_CRYPTO=""
LANPLUS_SAM="no"
LD_SAMX=""
- CFLAGS="-O2"
+ #CFLAGS="-O2"
SUBDIR_S="scripts util"
if test "x$cross_compiling" = "xyes"; then
# cross-compiling, so link with -static (e.g. Android ARM)
@@ -363,7 +363,7 @@
fi
rm -f $tmpc $tmpo >/dev/null 2>&1
echo $ECHO_N "checking compile fortify flags ... $ECHO_C"
- cfhard="-fstack-protector --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2"
+ #cfhard="-fstack-protector --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2"
echo "int main() { alloca(100); return(1); }" >$tmpc
$CC -o $tmpo $cfhard $tmpc >/dev/null 2>&1
if test $? -ne 0 ; then