You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/www-apps/liquid_feedback_core/files/liquid_feedback_core-2.2.3-...

25 lines
609 B

--- a/Makefile
+++ b/Makefile
@@ -1,16 +1,10 @@
all:: lf_update lf_update_suggestion_order
-lf_update: lf_update.c
- cc -Wall -O2 \
- -I "`pg_config --includedir`" \
- -L "`pg_config --libdir`" \
- -o lf_update lf_update.c -lpq
-
-lf_update_suggestion_order: lf_update_suggestion_order.c
- cc -Wall -O2 \
- -I "`pg_config --includedir`" \
- -L "`pg_config --libdir`" \
- -o lf_update_suggestion_order lf_update_suggestion_order.c -lpq
+CPPFLAGS=-I `pg_config --includedir`
+LDFLAGS=-L `pg_config --libdir`
+CFLAGS=-Wall -O2
+CC=cc
+LDLIBS=-lpq
clean::
rm -f lf_update lf_update_suggestion_order