You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/x11-wm/awesome/files/awesome-4.0-cflag-cleanup.p...

12 lines
395 B

--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -98,7 +98,7 @@
# CFLAGS
set(AWESOME_C_FLAGS
- -O1 -std=gnu99 -ggdb3 -fno-strict-aliasing -Wall -Wextra
+ -std=gnu99 -fno-strict-aliasing -Wall -Wextra
-Wchar-subscripts -Wundef -Wshadow -Wcast-align -Wwrite-strings
-Wsign-compare -Wunused -Wno-unused-parameter -Wuninitialized -Winit-self
-Wpointer-arith -Wformat-nonliteral