You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/x11-wm/cwm/files/cwm-Makefile.patch

20 lines
533 B

--- a/Makefile
+++ b/Makefile
@@ -13,12 +13,14 @@ OBJS= calmwm.o screen.o xmalloc.o client.o menu.o \
search.o util.o xutil.o conf.o xevents.o group.o \
kbfunc.o strlcpy.o strlcat.o y.tab.o \
strtonum.o reallocarray.o
+
+PKG_CONFIG?= pkg-config
-CPPFLAGS+= `pkg-config --cflags x11 xft xrandr`
+CPPFLAGS+= `${PKG_CONFIG} --cflags x11 xft xrandr`
CFLAGS?= -Wall -O2 -g -D_GNU_SOURCE
-LDFLAGS+= `pkg-config --libs x11 xft xrandr`
+LDFLAGS+= `${PKG_CONFIG} --libs x11 xft xrandr`
MANPREFIX?= ${PREFIX}/share/man