You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-sound/vitunes/files/vitunes-2.3-asneeded.patch

21 lines
571 B

--- vitunes-2.3/Makefile.linux.orig
+++ vitunes-2.3/Makefile.linux
@@ -12,7 +12,7 @@
# build info
CC?=/usr/bin/cc
CFLAGS+=-c -std=gnu99 -D_GNU_SOURCE -Wall -Wextra -Wno-unused-value $(CDEPS) $(CDEBUG)
-LDFLAGS+=-lm -lncurses -lutil $(LDEPS)
+LIBS=-lm -lncurses -lutil $(LDEPS)
OBJS=commands.o compat.o e_commands.o \
keybindings.o medialib.o meta_info.o \
@@ -27,7 +27,7 @@
.PHONY: debug clean install uninstall publish-repos man-debug
vitunes: $(OBJS)
- $(CC) -o $@ $(LDFLAGS) $(OBJS)
+ $(CC) -o $@ $(LDFLAGS) $(OBJS) $(LIBS)
.c.o:
$(CC) $(CFLAGS) $<