You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-perl/PDL/files/PDL-2.17.0-fortran.patch

23 lines
654 B

--- a/Lib/Minuit/Makefile.PL
+++ b/Lib/Minuit/Makefile.PL
@@ -149,7 +149,7 @@
("
minuitlib/$_\$(OBJ_EXT): minuitlib/$_.f
- $mycompiler -c $hack_64bit -o minuitlib/$_\$(OBJ_EXT) $mycflags minuitlib/$_.f
+ \$(FC) \$(FFLAGS) -fPIC -c -o minuitlib/$_\$(OBJ_EXT) $mycflags minuitlib/$_.f
" )} @minuitfiles;
if (!defined($PDL::Config{MINUIT_LIB})){
--- a/Lib/Slatec/Makefile.PL
+++ b/Lib/Slatec/Makefile.PL
@@ -136,7 +136,7 @@
("
slatec/$_\$(OBJ_EXT): slatec/$_.f
- $mycompiler -c $hack_64bit -o slatec/$_\$(OBJ_EXT) $mycflags slatec/$_.f
+ \$(FC) \$(FFLAGS) -c -fPIC -o slatec/$_\$(OBJ_EXT) $mycflags slatec/$_.f
" )} @slatecfiles;
}