You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/kde-plasma/plasma-workspace/files/plasma-workspace-5.12.80-te...

18 lines
905 B

diff --git a/dataengines/notifications/CMakeLists.txt b/dataengines/notifications/CMakeLists.txt
index 8a90cb59..597b3f7e 100644
--- a/dataengines/notifications/CMakeLists.txt
+++ b/dataengines/notifications/CMakeLists.txt
@@ -46,7 +46,8 @@ ecm_qt_declare_logging_category(notifications_test_SRCS HEADER debug.h
IDENTIFIER NOTIFICATIONS
CATEGORY_NAME kde.dataengine.notifications`
DEFAULT_SEVERITY Info)
-
-add_executable(notification_test ${notifications_test_SRCS})
-target_link_libraries(notification_test Qt5::Test Qt5::Core)
-ecm_mark_as_test(notification_test)
+if(BUILD_TESTING)
+ add_executable(notification_test ${notifications_test_SRCS})
+ target_link_libraries(notification_test Qt5::Test Qt5::Core)
+ ecm_mark_as_test(notification_test)
+endif()