You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-libs/linux-gpib/files/linux-gpib-3.2.21-build.patch

45 lines
1.6 KiB

diff -ruN linux-gpib-3.2.21.orig/drivers/Makefile.am linux-gpib-3.2.21/drivers/Makefile.am
--- linux-gpib-3.2.21.orig/drivers/Makefile.am 2014-12-13 11:27:55.000000000 +0100
+++ linux-gpib-3.2.21/drivers/Makefile.am 2014-12-17 17:51:47.152588400 +0100
@@ -28,39 +28,13 @@
CC="$(LINUX_CC) -I@abs_top_srcdir@ -I@abs_top_srcdir@/drivers/gpib/include -I@abs_top_srcdir@/include" \
SUBDIRS="$(GPIB_ABS_MODULE_SUBDIR)"
-install-data-hook: device-file-check /etc/gpib.conf
+install-data-hook: /etc/gpib.conf
$(MAKE) -C $(LINUX_SRCDIR) V=1 modules_install\
CC="$(LINUX_CC) -I@abs_top_srcdir@ -I@abs_top_srcdir@/driver/include -I@abs_top_srcdir@/include" \
SUBDIRS="$(GPIB_ABS_MODULE_SUBDIR)" INSTALL_MOD_DIR="gpib"
- $(DEPMOD) -a
-
-/dev/gpib0:
- groupadd gpib || echo "group gpib exists"
- for i in `seq 0 15`; \
- do \
- mknod -m u=rw,g=rw,o= /dev/gpib$${i} c $(IBMAJOR) $${i} || exit 1; \
- chown root:gpib /dev/gpib$${i}; \
- done
-
-.PHONY : device-file-check
-device-file-check: /dev/gpib0
- @if [ ! -c /dev/gpib0 ]; then \
- if [ -a /dev/gpib0 ]; then \
- echo "A file or directory called /dev/gpib0 exists but it is not" \
- "a character device. Delete or move it and try again."; \
- exit 1; \
- fi; \
- fi
- @ls -l /dev/gpib0 | grep -q "$(IBMAJOR)"; \
- if [ $$? != 0 ]; then \
- echo "/dev/gpib0 has the wrong major number. " \
- "Delete your /dev/gpibX files and try again."; \
- exit 1; \
- fi
#should move this to util/templates Makefile.am when it exists
/etc/gpib.conf:
- $(INSTALL_DATA) -D $(top_srcdir)/util/templates/gpib.conf /etc/gpib.conf
#make sure compiled files, etc don't make it into distribution tarballs
dist-hook: