You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-emulation/libvirt/files/libvirt-8.7.0-meson-Stop-de...

56 lines
2.0 KiB

From ab5ce6ac561b9ef5d97ee8268df048b3432d7b8b Mon Sep 17 00:00:00 2001
Message-Id: <ab5ce6ac561b9ef5d97ee8268df048b3432d7b8b.1679397051.git.mprivozn@redhat.com>
From: Michal Privoznik <mprivozn@redhat.com>
Date: Mon, 20 Mar 2023 13:38:27 +0100
Subject: [PATCH] meson: Stop detecting -Wl,--version-script=
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
With its version 16.0, the LLVM's linker turned on
--no-undefined-version by default [1]. This breaks how we detect
--version-script= detection, because at the compile time there's
no library built yet that we can use to make --version-script=
happy. Unfortunately, meson does not provide a way to detect this
either [2].
But there's not much sense in detecting the argument either. We
already special case some systems (windows, darwin) and do the
check for others, which are expected to support versioned
symbols, because of ELF. Worst case scenario - the error is
reported during compile time rather than configure time.
1: https://reviews.llvm.org/D135402
2: https://github.com/mesonbuild/meson/issues/3047
Resolves: https://bugs.gentoo.org/902211
Signed-off-by: Michal Privoznik <mprivozn@redhat.com>
Reviewed-by: Daniel P. Berrangé <berrange@redhat.com>
(cherry picked from commit 743fdb97c81f38adc6e9b55f402244f7982352f4)
Signed-off-by: Michal Privoznik <mprivozn@redhat.com>
---
meson.build | 7 +------
1 file changed, 1 insertion(+), 6 deletions(-)
diff --git a/meson.build b/meson.build
index 0b3187ad88..53156329a4 100644
--- a/meson.build
+++ b/meson.build
@@ -514,12 +514,7 @@ elif host_machine.system() == 'darwin'
# macOS libraries don't support symbol versioning
version_script_flags = ''
else
- test_file = '@0@/src/libvirt_qemu.syms'.format(meson.source_root())
- if cc.has_link_argument('-Wl,--version-script=@0@'.format(test_file))
- version_script_flags = '-Wl,--version-script='
- else
- error('No supported version script link argument found.')
- endif
+ version_script_flags = '-Wl,--version-script='
endif
libvirt_flat_namespace = []
--
2.39.2