You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-chemistry/burrow-owl/files/1.4-glibc-2.12.patch

39 lines
631 B

Fix build with GLIBC-2.12
http://bugs.gentoo.org/show_bug.cgi?id=333843
--- src/Makefile.am
+++ src/Makefile.am
@@ -82,8 +82,8 @@
painter.h \
ticket.c \
ticket.h \
-endian.c \
-endian.h \
+bo_endian.c \
+bo_endian.h \
version.c \
version.h
--- src/hosbackingfile.c
+++ src/hosbackingfile.c
@@ -18,6 +18,7 @@
*/
#include "hosbackingfile.h"
+#include "bo_endian.h"
#define DEFAULT_BUF_SIZE 512
--- src/nih.c
+++ src/nih.c
@@ -24,7 +24,7 @@
#include "hosdimensionblock.h"
#include "hosbackingblock.h"
#include "hosbackingfile.h"
-#include "endian.h"
+#include "bo_endian.h"
/* --- header contents ----
*