You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-i18n/xsim/files/xsim-0.3.9.4-makefile.patch

154 lines
3.8 KiB

diff --git a/Makefile.in b/Makefile.in
index 6a7a195..6d2b4e6 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -36,7 +36,7 @@ distclean: clean
done && test -z "$$fail"
install-data:
- cd plugins/IMs;make install-data
+ cd plugins/IMs;$(MAKE) install-data
uninstall:
@for dir in ${subdirs}; do \
diff --git a/plugins/IMs/jianpin/Makefile.in b/plugins/IMs/jianpin/Makefile.in
index cbbac33..50d7ef0 100644
--- a/plugins/IMs/jianpin/Makefile.in
+++ b/plugins/IMs/jianpin/Makefile.in
@@ -25,7 +25,7 @@ OBJS=simpleim.o simpleimc.o pyphraser.o
TARGET=jianpin.so
all:$(TARGET)
- cd dict; make
+ cd dict; $(MAKE)
jianpin.so:$(OBJS)
$(LD_SHAREEXE) -shared -o $(TARGET) $(OBJS) $(LDFLAGS) -L$(bdblibs) $(LIBS) -l$(bdblib) $(gcclib)
@@ -41,20 +41,20 @@ pyphraser.o:pyphraser.cpp pyphraser.h simpleimc.h $(include_path)wstring.h
clean:
rm -f *.o $(TARGET) core *~ *.bak
- cd dict; make clean
+ cd dict; $(MAKE) clean
distclean:clean
rm -rf Makefile
- cd dict; make distclean
+ cd dict; $(MAKE) distclean
install:all
$(topdir)/mkinstalldirs $(xsim_libp)
cp -f $(TARGET) $(xsim_libp)
- cd dict; make install
+ cd dict; $(MAKE) install
install-data:
- cd dict;make install-data
+ cd dict;$(MAKE) install-data
uninstall:
cd $(xsim_libp); rm -f $(TARGET)
- cd dict;make uninstall
+ cd dict;$(MAKE) uninstall
diff --git a/plugins/IMs/table/Makefile.in b/plugins/IMs/table/Makefile.in
index a747560..cbc67bc 100644
--- a/plugins/IMs/table/Makefile.in
+++ b/plugins/IMs/table/Makefile.in
@@ -25,7 +25,7 @@ OBJS=tableim.o tableimc.o
TARGET=table.so
all:$(TARGET)
- cd dict; make
+ cd dict; $(MAKE)
$(TARGET):$(OBJS)
$(LD_SHAREEXE) -shared -o $(TARGET) $(OBJS) $(LDFLAGS) -L$(bdblibs) $(LIBS) -l$(bdblib) $(gcclib)
@@ -38,20 +38,20 @@ tableimc.o:tableimc.h tableimc.cpp $(include_path)wstring.h $(include_path)imc.h
clean:
rm -f *.o $(TARGET) core *~ *.bak
- cd dict; make clean
+ cd dict; $(MAKE) clean
distclean:clean
rm -rf Makefile
- cd dict; make distclean
+ cd dict; $(MAKE) distclean
install:all
$(topdir)/mkinstalldirs $(xsim_libp)
cp -f $(TARGET) $(xsim_libp)
- cd dict; make install
+ cd dict; $(MAKE) install
install-data:
- cd dict;make install-data
+ cd dict;$(MAKE) install-data
uninstall:
cd $(xsim_libp); rm -f $(TARGET)
- cd dict; make uninstall
+ cd dict; $(MAKE) uninstall
diff --git a/plugins/IMs/wubi/Makefile.in b/plugins/IMs/wubi/Makefile.in
index 031f1a7..c3d0f88 100644
--- a/plugins/IMs/wubi/Makefile.in
+++ b/plugins/IMs/wubi/Makefile.in
@@ -25,7 +25,7 @@ OBJS=wubiim.o wubiimc.o
TARGET=wubi.so
all:$(TARGET)
- cd dict; make
+ cd dict; $(MAKE)
$(TARGET):$(OBJS)
$(LD_SHAREEXE) -shared -o $(TARGET) $(OBJS) $(LDFLAGS) -L$(bdblibs) $(LIBS) -l$(bdblib) $(gcclib)
@@ -38,20 +38,20 @@ wubiimc.o:wubiimc.h wubiimc.cpp $(include_path)wstring.h $(include_path)imc.h
clean:
rm -f *.o $(TARGET) core *~ *.bak
- cd dict; make clean
+ cd dict; $(MAKE) clean
distclean:clean
rm -rf Makefile
- cd dict; make distclean
+ cd dict; $(MAKE) distclean
install:all
$(topdir)/mkinstalldirs $(xsim_libp)
cp -f $(TARGET) $(xsim_libp)
- cd dict; make install
+ cd dict; $(MAKE) install
install-data:
- cd dict;make install-data
+ cd dict;$(MAKE) install-data
uninstall:
cd $(xsim_libp); rm -f $(TARGET)
- cd dict; make uninstall
+ cd dict; $(MAKE) uninstall
diff --git a/xsim/Makefile.in b/xsim/Makefile.in
index d618a2c..bbe1599 100644
--- a/xsim/Makefile.in
+++ b/xsim/Makefile.in
@@ -58,15 +58,15 @@ wstring.o:wstring.h wstring.cpp
$(CXX) -c wstring.cpp $(CXXFLAGS) -I./IMdkit
IMdkit/libXimd.a:
- cd IMdkit;make
+ cd IMdkit;$(MAKE)
clean:
rm -f *.o xsim core *~ *.bak
- cd IMdkit; make clean
+ cd IMdkit; $(MAKE) clean
distclean:clean
rm -rf Makefile tags
- cd IMdkit; make distclean
+ cd IMdkit; $(MAKE) distclean
install:all
$(topdir)/mkinstalldirs $(xsim_binp)