You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-libs/rocm-comgr/files/rocm-comgr-2.6.0-unbundle-y...

31 lines
1.1 KiB

diff --git a/lib/comgr/CMakeLists.txt b/lib/comgr/CMakeLists.txt
index 454b830..70e2526 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -90,12 +90,8 @@ if (UNIX)
-Wl,--no-undefined)
endif()
endif()
- # FIXME: Remove when yaml-cpp is removed from the build.
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fPIC")
else()
list(APPEND AMD_COMGR_PRIVATE_COMPILE_OPTIONS "/W0" "/wd4244")
- # FIXME: Make this private once yaml-cpp is removed from the build.
- add_definitions(-D_HAS_EXCEPTIONS=0)
endif()
# Windows is strict about visibility of exports in shared libraries, so we ask
@@ -179,10 +175,8 @@ install(EXPORT amd_comgr_export
DESTINATION "${AMD_COMGR_PACKAGE_PREFIX}"
FILE "${AMD_COMGR_TARGETS_NAME}")
-set(YAML_CPP_BUILD_TESTS OFF CACHE BOOL "Enable testing" FORCE)
-set(YAML_CPP_BUILD_TOOLS OFF CACHE BOOL "Enable parse tools" FORCE)
-add_subdirectory(yaml-cpp EXCLUDE_FROM_ALL)
-include_directories(./yaml-cpp/include)
+find_package(yaml-cpp REQUIRED)
+include_directories(${YAML_CPP_INCLUDE_DIR})
set(CLANG_LIBS
clangFrontendTool)