You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-admin/cancd/cancd-0.1.0-r4.ebuild

44 lines
1.1 KiB

# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit user
DESCRIPTION="CA NetConsole Daemon receives output from the Linux netconsole driver"
HOMEPAGE="http://oss.oracle.com/projects/cancd/"
SRC_URI="http://oss.oracle.com/projects/cancd/dist/files/source/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
PATCHES=(
"${FILESDIR}/${P}-build-r1.patch"
"${FILESDIR}/${P}-c-cleanup.patch"
)
src_prepare() {
default
# slight makefile cleanup
sed -i \
-e '/^CFLAGS/s,-g,,' \
-e '/^CFLAGS/s,-O2,-Wall -W -Wextra -Wundef -Wendif-labels -Wshadow -Wpointer-arith -Wbad-function-cast -Wcast-qual -Wcast-align -Wwrite-strings -Wconversion -Wsign-compare -Waggregate-return -Wstrict-prototypes -Wredundant-decls -Wunreachable-code -Wlong-long,' \
-e '/rm cancd cancd.o/s,rm,rm -f,' \
Makefile || die
}
src_install() {
dosbin cancd
newinitd "${FILESDIR}"/cancd-init.d-r1 cancd
newconfd "${FILESDIR}"/cancd-conf.d-r1 cancd
newinitd "${FILESDIR}"/netconsole-init.d netconsole
newconfd "${FILESDIR}"/netconsole-conf.d netconsole
}
pkg_preinst() {
enewuser cancd
}