You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-dicts/prime-dict/prime-dict-1.0.0-r3.ebuild

33 lines
634 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
USE_RUBY="ruby25 ruby26 ruby27 ruby30"
inherit ruby-ng
DESCRIPTION="Dictionary files for PRIME input method"
HOMEPAGE="http://taiyaki.org/prime/"
SRC_URI="http://prime.sourceforge.jp/src/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 ~hppa ppc ppc64 ~sparc x86"
IUSE=""
each_ruby_configure() {
econf --with-rubydir="$(ruby_rbconfig_value 'sitelibdir')"
}
each_ruby_compile() {
emake
}
each_ruby_install() {
emake DESTDIR="${D}" install
}
all_ruby_install() {
dodoc AUTHORS ChangeLog NEWS README
}