You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-emulation/qemu-init-scripts/qemu-init-scripts-0.3.0-r1....

36 lines
896 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DESCRIPTION="Kvm and qemu init scripts"
HOMEPAGE="https://gitweb.gentoo.org/proj/kvm-tools.git/"
SRC_URI="https://dev.gentoo.org/~dolsen/releases/${PN}/${P}.tar.xz"
LICENSE="GPL-2"
SLOT=0
KEYWORDS="~amd64 ~x86"
RDEPEND="
app-emulation/qemu
net-misc/socat"
S="${WORKDIR}/${PN}"
PATCHES=( "${FILESDIR}"/openrc-run.patch )
src_install() {
newinitd "${S}/"qemu-init-script qemu
newconfd "${S}/"qemu-conf.example qemu.conf.example
newsbin "${S}/"qtap-manipulate qtap-manipulate
dosym qemu /etc/init.d/kvm
}
pkg_postinst() {
elog "For bridging networking systems, you need these run time utilities:"
elog " net-misc/bridge-utils"
elog " sys-apps/usermode-utilities"
elog ""
elog "We will be updating these scripts to use"
elog "iptables exclusively in the future"
}