You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-emulation/spectemu/spectemu-0.99.3-r1.ebuild

51 lines
892 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit autotools
DESCRIPTION="48k ZX Spectrum Emulator"
HOMEPAGE="http://kempelen.iit.bme.hu/~mszeredi/spectemu/spectemu.html"
SRC_URI="http://www.inf.bme.hu/~mszeredi/spectemu/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE="readline svga +X"
REQUIRED_USE="|| ( svga X )"
DEPEND="
X? (
x11-base/xorg-proto
>=x11-libs/libX11-1.0.0
>=x11-libs/libXext-1.0.0
>=x11-libs/libXxf86vm-1.0.0
)
readline? ( sys-libs/readline:= )
"
RDEPEND="${DEPEND}
svga? ( media-libs/svgalib )"
PATCHES=(
"${FILESDIR}"/${P}-automagic.patch
"${FILESDIR}"/${P}-build.patch
)
src_prepare() {
default
eautoreconf
}
src_configure() {
econf \
$(use_with readline) \
$(use_with svga) \
$(use_with X x)
}
src_install() {
emake install_root="${ED}" install
}