You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-portage/repo-commit/repo-commit-0.4.1-r1.ebuild

28 lines
565 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit out-of-source
if [[ ${PV} == *9999 ]]; then
EGIT_REPO_URI="https://bitbucket.org/gentoo/${PN}.git"
inherit autotools git-r3
else
SRC_URI="https://www.bitbucket.org/gentoo/${PN}/downloads/${P}.tar.bz2"
KEYWORDS="~amd64 ~x86"
fi
DESCRIPTION="A repository commit helper"
HOMEPAGE="https://bitbucket.org/gentoo/repo-commit/"
LICENSE="BSD"
SLOT="0"
RDEPEND="sys-apps/portage"
src_prepare() {
default
[[ ${PV} == *9999 ]] && eautoreconf
}