You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-db/lmdb++/lmdb++-1.0.0.ebuild

29 lines
663 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
MY_P="${P/lmdb++/lmdbxx}"
S="${WORKDIR}/${MY_P}"
DESCRIPTION="C++11 wrapper for the LMDB database library"
HOMEPAGE="https://github.com/hoytech/lmdbxx"
SRC_URI="https://github.com/hoytech/lmdbxx/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
LICENSE="public-domain"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="dev-db/lmdb"
src_install() {
emake PREFIX="${D}/usr" install
dodoc AUTHORS CREDITS INSTALL README.md TODO UNLICENSE
}
src_test() {
emake CXXFLAGS="-g -std=c++17 ${CXXFLAGS}" LDFLAGS="${LDFLAGS}" check
}