You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-haskell/aeson-compat/aeson-compat-0.3.9-r2.ebuild

59 lines
2.6 KiB

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
# ebuild generated by hackport 0.5.6.9999
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
DESCRIPTION="Compatibility layer for aeson"
HOMEPAGE="https://github.com/phadej/aeson-compat#readme"
SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE=""
RDEPEND=">=dev-haskell/aeson-0.7.0.6:=[profile?] <dev-haskell/aeson-1.5:=[profile?]
>=dev-haskell/attoparsec-0.12:=[profile?] <dev-haskell/attoparsec-0.14:=[profile?]
>=dev-haskell/attoparsec-iso8601-1.0.0.0:=[profile?] <dev-haskell/attoparsec-iso8601-1.1:=[profile?]
>=dev-haskell/base-compat-0.6.0:=[profile?]
>=dev-haskell/exceptions-0.8:=[profile?] <dev-haskell/exceptions-0.11:=[profile?]
>=dev-haskell/hashable-1.2:=[profile?]
>=dev-haskell/nats-1.1.2:=[profile?] <dev-haskell/nats-1.2:=[profile?]
>=dev-haskell/scientific-0.3:=[profile?] <dev-haskell/scientific-0.4:=[profile?]
>=dev-haskell/semigroups-0.18.5:=[profile?]
>=dev-haskell/tagged-0.7.3:=[profile?] <dev-haskell/tagged-0.9:=[profile?]
>=dev-haskell/text-1.2:=[profile?] <dev-haskell/text-1.3:=[profile?]
>=dev-haskell/time-locale-compat-0.1.0.1:=[profile?] <dev-haskell/time-locale-compat-0.2:=[profile?]
>=dev-haskell/unordered-containers-0.2:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?]
>=dev-haskell/vector-0.10:=[profile?] <dev-haskell/vector-0.13:=[profile?]
>=dev-haskell/void-0.7.2:=[profile?] <dev-haskell/void-0.8:=[profile?]
>=dev-lang/ghc-7.6.1:=
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.16.0
test? ( >=dev-haskell/base-orphans-0.4.5 <dev-haskell/base-orphans-0.9
>=dev-haskell/quickcheck-2.10
>=dev-haskell/quickcheck-instances-0.3.16 <dev-haskell/quickcheck-instances-0.4
>=dev-haskell/tasty-0.10
>=dev-haskell/tasty-hunit-0.9 <dev-haskell/tasty-hunit-0.11
>=dev-haskell/tasty-quickcheck-0.8 <dev-haskell/tasty-quickcheck-0.11 )
"
src_prepare() {
default
cabal_chdeps \
'base >=4.6 && <4.13' 'base >=4.6' \
'base-compat >=0.6.0 && <0.11' 'base-compat >=0.6.0' \
'hashable >=1.2 && <1.3' 'hashable >=1.2' \
'semigroups >=0.18.5 && <0.19' 'semigroups >=0.18.5' \
'time >=1.4.0.1 && <1.9' 'time >=1.4.0.1' \
'tasty >=0.10 && <1.2' 'tasty >=0.10' \
'QuickCheck >=2.10 && <2.13' 'QuickCheck >=2.10'
}