You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-haskell/cairo/cairo-0.13.8.1.ebuild

39 lines
1.1 KiB

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
# ebuild generated by hackport 0.6.4.9999
#hackport: flags: cairo_ps:postscript,cairo_pdf:pdf,cairo_svg:svg
CABAL_FEATURES="lib profile haddock hoogle hscolour"
inherit haskell-cabal
DESCRIPTION="Binding to the Cairo library"
HOMEPAGE="http://projects.haskell.org/gtk2hs/"
SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE="+pdf +postscript +svg"
RDEPEND="dev-haskell/mtl:=[profile?]
>=dev-haskell/text-1.0.0.0:=[profile?] <dev-haskell/text-1.3:=[profile?]
>=dev-haskell/utf8-string-0.2:=[profile?] <dev-haskell/utf8-string-1.1:=[profile?]
>=dev-lang/ghc-7.10.1:=
x11-libs/cairo
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.24 <dev-haskell/cabal-3.3
>=dev-haskell/gtk2hs-buildtools-0.13.2.0 <dev-haskell/gtk2hs-buildtools-0.14
virtual/pkgconfig
"
src_configure() {
haskell-cabal_src_configure \
$(cabal_flag pdf cairo_pdf) \
$(cabal_flag postscript cairo_ps) \
$(cabal_flag svg cairo_svg)
}