You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-haskell/cipher-aes128/cipher-aes128-0.7.0.5-r1.eb...

42 lines
893 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
# ebuild generated by hackport 0.6.2
#hackport: flags: -test,-halvm
CABAL_FEATURES="lib profile haddock hoogle hscolour"
inherit haskell-cabal
DESCRIPTION="AES and common modes using AES-NI when available"
HOMEPAGE="https://github.com/TomMD/cipher-aes128"
SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE=""
RDEPEND="dev-haskell/cereal:=[profile?]
>=dev-haskell/crypto-api-0.13:=[profile?]
dev-haskell/tagged:=[profile?]
>=dev-lang/ghc-7.8.2:=
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.18.1.3 <dev-haskell/cabal-3.3
"
src_prepare() {
default
cabal_chdeps \
'Cabal >= 1.10 && < 3.1' 'Cabal >= 1.10 && < 3.3'
}
src_configure() {
haskell-cabal_src_configure \
--flag=-halvm \
--flag=-test
}