You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-haskell/comonad/comonad-5.0.7.ebuild

43 lines
1.4 KiB

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
# ebuild generated by hackport 0.6.6.9999
#hackport: flags: +distributive,+containers,test-doctests:test
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
DESCRIPTION="Haskell package providing comonads"
HOMEPAGE="https://github.com/ekmett/comonad/"
SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE="+indexed-traversable"
RESTRICT=test # fails on USE=doc
RDEPEND=">=dev-haskell/distributive-0.2.2:=[profile?] <dev-haskell/distributive-1:=[profile?]
>=dev-haskell/semigroups-0.16.2:=[profile?] <dev-haskell/semigroups-1:=[profile?]
>=dev-haskell/tagged-0.7:=[profile?] <dev-haskell/tagged-1:=[profile?]
>=dev-haskell/transformers-compat-0.3:=[profile?] <dev-haskell/transformers-compat-1:=[profile?]
>=dev-lang/ghc-7.8.2:=
indexed-traversable? ( >=dev-haskell/indexed-traversable-0.1:=[profile?] <dev-haskell/indexed-traversable-0.2:=[profile?] )
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.18.1.3
>=dev-haskell/cabal-doctest-1 <dev-haskell/cabal-doctest-1.1
test? ( >=dev-haskell/doctest-0.11.1 <dev-haskell/doctest-0.18 )
"
src_configure() {
haskell-cabal_src_configure \
--flag=containers \
--flag=distributive \
$(cabal_flag indexed-traversable indexed-traversable) \
$(cabal_flag test test-doctests)
}