You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-haskell/exceptions/exceptions-0.10.4.ebuild

42 lines
1.3 KiB

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
# ebuild generated by hackport 0.6.4.9999
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
DESCRIPTION="Extensible optionally-pure exceptions"
HOMEPAGE="https://github.com/ekmett/exceptions/"
SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE=""
RDEPEND=">=dev-haskell/fail-4.9:=[profile?] <dev-haskell/fail-4.10:=[profile?]
>=dev-haskell/mtl-2.0:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
>=dev-haskell/stm-2.2:=[profile?] <dev-haskell/stm-3:=[profile?]
>=dev-haskell/transformers-compat-0.3:=[profile?] <dev-haskell/transformers-compat-0.7:=[profile?]
>=dev-lang/ghc-7.8.2:=
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.18.1.3
test? ( >=dev-haskell/quickcheck-2.5 <dev-haskell/quickcheck-2.15
>=dev-haskell/test-framework-0.8 <dev-haskell/test-framework-0.9
>=dev-haskell/test-framework-hunit-0.3 <dev-haskell/test-framework-hunit-0.4
>=dev-haskell/test-framework-quickcheck2-0.3 <dev-haskell/test-framework-quickcheck2-0.4 )
"
CABAL_CORE_LIB_GHC_PV="PM:8.10.1 PM:8.10.2 PM:8.10.3 PM:8.10.4 PM:9.0.1 PM:9999"
src_prepare() {
default
cabal_chdeps \
'QuickCheck >= 2.5 && < 2.14' 'QuickCheck >= 2.5'
}