You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-haskell/filestore/filestore-0.6.5.ebuild

40 lines
1.2 KiB

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
# ebuild generated by hackport 0.6.6.9999
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
DESCRIPTION="Interface for versioning file stores"
HOMEPAGE="https://hackage.haskell.org/package/filestore"
SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE="+maxcount"
RESTRICT=test # requires mercurial
RDEPEND=">=dev-haskell/diff-0.4:=[profile?] <dev-haskell/diff-0.5:=[profile?]
>=dev-haskell/old-locale-1.0:=[profile?] <dev-haskell/old-locale-1.1:=[profile?]
>=dev-haskell/parsec-2:=[profile?] <dev-haskell/parsec-3.2:=[profile?]
>=dev-haskell/split-0.1:=[profile?] <dev-haskell/split-0.3:=[profile?]
>=dev-haskell/utf8-string-0.3:=[profile?] <dev-haskell/utf8-string-1.1:=[profile?]
>=dev-haskell/xml-1.3:=[profile?] <dev-haskell/xml-1.4:=[profile?]
>=dev-lang/ghc-7.10.1:=
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.22.2.0
test? ( >=dev-haskell/hunit-1.2 <dev-haskell/hunit-1.7
dev-haskell/mtl )
"
src_configure() {
haskell-cabal_src_configure \
$(cabal_flag maxcount maxcount)
}