You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-haskell/glob/glob-0.9.3.ebuild

38 lines
1.2 KiB

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
# ebuild generated by hackport 0.5.6.9999
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
MY_PN="Glob"
MY_P="${MY_PN}-${PV}"
DESCRIPTION="Globbing library"
HOMEPAGE="http://iki.fi/matti.niemenmaa/glob/"
SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE=""
RDEPEND=">=dev-haskell/dlist-0.4:=[profile?] <dev-haskell/dlist-0.9:=[profile?]
>=dev-haskell/semigroups-0.18:=[profile?] <dev-haskell/semigroups-0.19:=[profile?]
>=dev-haskell/transformers-compat-0.3:=[profile?] <dev-haskell/transformers-compat-0.7:=[profile?]
>=dev-lang/ghc-7.8.2:=
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.18.1.3
test? ( >=dev-haskell/hunit-1.2 <dev-haskell/hunit-1.7
>=dev-haskell/quickcheck-2 <dev-haskell/quickcheck-3
>=dev-haskell/test-framework-0.2 <dev-haskell/test-framework-1
>=dev-haskell/test-framework-hunit-0.2 <dev-haskell/test-framework-hunit-1
>=dev-haskell/test-framework-quickcheck2-0.3 <dev-haskell/test-framework-quickcheck2-1 )
"
S="${WORKDIR}/${MY_P}"