You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-haskell/gluraw/gluraw-2.0.0.4.ebuild

38 lines
849 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
# ebuild generated by hackport 0.5.6.9999
#hackport: flags: -usenativewindowslibraries
CABAL_FEATURES="lib profile haddock hoogle hscolour"
inherit haskell-cabal
MY_PN="GLURaw"
MY_P="${MY_PN}-${PV}"
DESCRIPTION="A raw binding for the OpenGL graphics system"
HOMEPAGE="https://www.haskell.org/haskellwiki/Opengl"
SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE=""
RDEPEND=">=dev-haskell/openglraw-3.0:=[profile?] <dev-haskell/openglraw-3.4:=[profile?]
>=dev-lang/ghc-7.8.2:=
virtual/glu
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.18.1.3
"
S="${WORKDIR}/${MY_P}"
src_configure() {
haskell-cabal_src_configure \
--flag=-usenativewindowslibraries
}