You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-haskell/hit/hit-0.7.0.ebuild

34 lines
668 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
# ebuild generated by hackport 0.6.2
CABAL_FEATURES=""
inherit haskell-cabal
DESCRIPTION="Git operations in haskell"
HOMEPAGE="https://github.com/vincenthz/hit"
SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="debug"
RDEPEND=">=dev-haskell/git-0.3.0:=
>=dev-haskell/hashable-1.2:=
dev-haskell/hashtables:=
dev-haskell/hourglass:=
>=dev-lang/ghc-7.4.1:=
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.8
"
src_configure() {
haskell-cabal_src_configure \
$(cabal_flag debug debug)
}