You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-haskell/htf/htf-0.14.0.3.ebuild

49 lines
1.2 KiB

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
# ebuild generated by hackport 0.6.6.9999
CABAL_FEATURES="lib haddock hoogle hscolour" # test-suite: needs htfpp already installed, profile crashes cpp
inherit haskell-cabal
MY_PN="HTF"
MY_P="${MY_PN}-${PV}"
DESCRIPTION="The Haskell Test Framework"
HOMEPAGE="https://github.com/skogsbaer/HTF/"
SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE=""
RESTRICT=test # needs stack, needs htfpp already installed
RDEPEND=">=dev-haskell/aeson-0.11:=
dev-haskell/base64-bytestring:=
>=dev-haskell/cpphs-1.19:=
>=dev-haskell/diff-0.3:=
dev-haskell/haskell-src:=
>=dev-haskell/hunit-1.2.5:=
>=dev-haskell/lifted-base-0.1:=
>=dev-haskell/monad-control-0.3:=
>=dev-haskell/mtl-1.1:=
>=dev-haskell/old-time-1.0:=
>=dev-haskell/quickcheck-2.3:2=
>=dev-haskell/random-1.0:=
>=dev-haskell/regex-compat-0.92:=
>=dev-haskell/text-0.11:=
dev-haskell/vector:=
>=dev-haskell/xmlgen-0.6:=
>=dev-lang/ghc-7.6.2:=
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-2.0
>=dev-haskell/cpphs-1.19
"
S="${WORKDIR}/${MY_P}"