You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-haskell/http-client-tls/http-client-tls-0.3.5.3.ebuild

40 lines
1.1 KiB

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
# ebuild generated by hackport 0.5.5.9999
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
DESCRIPTION="http-client backend using the connection package and tls library"
HOMEPAGE="https://github.com/snoyberg/http-client"
SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE=""
RESTRICT=test # needs network access
RDEPEND="dev-haskell/case-insensitive:=[profile?]
>=dev-haskell/connection-0.2.5:=[profile?]
dev-haskell/cryptonite:=[profile?]
dev-haskell/data-default-class:=[profile?]
dev-haskell/exceptions:=[profile?]
>=dev-haskell/http-client-0.5.0:=[profile?]
dev-haskell/http-types:=[profile?]
dev-haskell/memory:=[profile?]
dev-haskell/network:=[profile?]
dev-haskell/network-uri:=[profile?]
dev-haskell/text:=[profile?]
>=dev-haskell/tls-1.2:=[profile?]
>=dev-lang/ghc-7.8.2:=
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.18.1.3
test? ( dev-haskell/hspec )
"