You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-haskell/hxt/hxt-9.3.1.18.ebuild

36 lines
950 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
# ebuild generated by hackport 0.6.9999
CABAL_FEATURES="lib profile haddock hoogle hscolour"
inherit haskell-cabal
DESCRIPTION="A collection of tools for processing XML with Haskell"
HOMEPAGE="https://github.com/UweSchmidt/hxt"
SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE=""
RDEPEND=">=dev-haskell/hxt-charproperties-9.1:=[profile?]
>=dev-haskell/hxt-regex-xmlschema-9.2:=[profile?]
>=dev-haskell/hxt-unicode-9.0.1:=[profile?]
>=dev-haskell/mtl-2.0.1:=[profile?] <dev-haskell/mtl-3:=[profile?]
>=dev-haskell/parsec-2.1:=[profile?] <dev-haskell/parsec-4:=[profile?]
>=dev-lang/ghc-7.4.1:=
>=dev-haskell/network-uri-2.6:=[profile?]
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.8
"
src_configure() {
haskell-cabal_src_configure \
--flag=network-uri
}