You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-haskell/listlike/listlike-4.6.3.ebuild

39 lines
1.2 KiB

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
# ebuild generated by hackport 0.6.3
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
MY_PN="ListLike"
MY_P="${MY_PN}-${PV}"
DESCRIPTION="Generic support for list-like structures"
HOMEPAGE="https://github.com/ddssff/listlike"
SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE=""
RDEPEND=">=dev-haskell/dlist-0.7:=[profile?] <dev-haskell/dlist-0.9:=[profile?]
>=dev-haskell/fmlist-0.8:=[profile?] <dev-haskell/fmlist-0.10:=[profile?]
>=dev-haskell/semigroups-0.16:=[profile?] <dev-haskell/semigroups-0.20:=[profile?]
>=dev-haskell/text-0.11:=[profile?] <dev-haskell/text-1.3:=[profile?]
dev-haskell/utf8-string:=[profile?]
>=dev-haskell/vector-0.5:=[profile?] <dev-haskell/vector-0.13:=[profile?]
>=dev-lang/ghc-7.6.2:=
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.16.0
test? ( >=dev-haskell/hunit-1.2 <dev-haskell/hunit-2
>=dev-haskell/quickcheck-2.4 <dev-haskell/quickcheck-3
>=dev-haskell/random-1 <dev-haskell/random-2 )
"
S="${WORKDIR}/${MY_P}"