You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-haskell/microstache/microstache-1.0.1.1.ebuild

40 lines
1.2 KiB

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
# ebuild generated by hackport 0.5.5.9999
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
DESCRIPTION="Mustache templates for Haskell"
HOMEPAGE="https://github.com/phadej/microstache"
SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE=""
RDEPEND=">=dev-haskell/aeson-0.11:=[profile?]
>=dev-haskell/parsec-3.1.11:=[profile?] <dev-haskell/parsec-6.0:=[profile?]
>=dev-haskell/semigroups-0.18:=[profile?] <dev-haskell/semigroups-0.19:=[profile?]
>=dev-haskell/text-1.2:=[profile?] <dev-haskell/text-1.3:=[profile?]
>=dev-haskell/unordered-containers-0.2.5:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?]
>=dev-haskell/vector-0.11:=[profile?] <dev-haskell/vector-0.13:=[profile?]
>=dev-lang/ghc-7.8.2:=
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.18.1.3
test? ( >=dev-haskell/hspec-2.0 <dev-haskell/hspec-3.0 )
"
src_prepare() {
default
cabal_chdeps \
'aeson >=0.11 && < 1.3' 'aeson >=0.11' \
'containers >=0.4.2.1 && < 0.6' 'containers >=0.4.2.1'
}