You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-haskell/netlink/netlink-1.1.1.0.ebuild

35 lines
841 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
# ebuild generated by hackport 0.5.6
CABAL_FEATURES="lib profile haddock hoogle hscolour"
inherit haskell-cabal
DESCRIPTION="Netlink communication for Haskell"
HOMEPAGE="https://github.com/Ongy/netlink-hs"
SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE="generators"
RDEPEND=">=dev-haskell/cereal-0.3:=[profile?]
>=dev-haskell/monad-loops-0.3:=[profile?]
dev-haskell/pretty-hex:=[profile?]
>=dev-lang/ghc-7.6.1:=
generators? ( <dev-haskell/language-c-0.7:=[profile?]
dev-haskell/regex-pcre:=[profile?] )
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.16.0
"
src_configure() {
haskell-cabal_src_configure \
$(cabal_flag generators generators)
}