You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-haskell/optparse-simple/optparse-simple-0.1.1.3.ebuild

32 lines
764 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
# ebuild generated by hackport 0.6.6.9999
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
DESCRIPTION="Simple interface to optparse-applicative"
HOMEPAGE="https://github.com/fpco/optparse-simple#readme"
SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE="build-example"
RDEPEND=">=dev-haskell/githash-0.1.3.0:=[profile?]
dev-haskell/optparse-applicative:=[profile?]
>=dev-lang/ghc-8.0.2:=
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.24.2.0
"
src_configure() {
haskell-cabal_src_configure \
$(cabal_flag build-example build-example)
}