You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-haskell/parsec-numbers/parsec-numbers-0.1.0.ebuild

32 lines
739 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
# ebuild generated by hackport 0.5.6.9999
CABAL_FEATURES="lib profile haddock hoogle hscolour"
inherit haskell-cabal
DESCRIPTION="Utilities for parsing numbers from strings"
HOMEPAGE="https://hackage.haskell.org/package/parsec-numbers"
SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE="parsec1"
RDEPEND=">=dev-lang/ghc-7.4.1:=
parsec1? ( dev-haskell/parsec1:=[profile?] )
!parsec1? ( dev-haskell/parsec:=[profile?] )
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.6
"
src_configure() {
haskell-cabal_src_configure \
$(cabal_flag parsec1 parsec1)
}