You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-haskell/path-io/path-io-1.6.0-r1.ebuild

44 lines
1.1 KiB

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
# ebuild generated by hackport 0.6.1.9999
#hackport: flags: -dev
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
DESCRIPTION="Interface to 'directory' package for users of 'path'"
HOMEPAGE="https://github.com/mrkkrp/path-io"
SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE=""
RDEPEND=">=dev-haskell/dlist-0.8:=[profile?] <dev-haskell/dlist-0.9:=[profile?]
>=dev-haskell/exceptions-0.8:=[profile?] <dev-haskell/exceptions-0.11:=[profile?]
>=dev-haskell/path-0.6:=[profile?]
>=dev-haskell/temporary-1.1:=[profile?] <dev-haskell/temporary-1.4:=[profile?]
dev-haskell/unix-compat:=[profile?]
>=dev-lang/ghc-8.6.1:=
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-2.4.0.1
test? ( >=dev-haskell/hspec-2.0 <dev-haskell/hspec-3.0 )
"
src_prepare() {
default
cabal_chdeps \
'path >= 0.6 && < 0.7' 'path >= 0.6'
}
src_configure() {
haskell-cabal_src_configure \
--flag=-dev
}