You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-haskell/pcre-light/pcre-light-0.4.1.0.ebuild

36 lines
801 B

# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
# ebuild generated by hackport 0.6.1
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
DESCRIPTION="Portable regex library for Perl 5 compatible regular expressions"
HOMEPAGE="https://github.com/Daniel-Diaz/pcre-light"
SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
#IUSE="use-pkg-config"
IUSE=""
RDEPEND=">=dev-lang/ghc-7.4.1:=
dev-libs/libpcre
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.8.0
virtual/pkgconfig
test? ( >=dev-haskell/hunit-1.2.5.2
>=dev-haskell/mtl-2.1.3.2 )
"
src_configure() {
haskell-cabal_src_configure \
--flag=use-pkg-config \
--flag=-old_base
}