You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-haskell/persistent/persistent-2.10.5.2.ebuild

51 lines
1.4 KiB

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
# ebuild generated by hackport 0.6.6.9999
#hackport: flags: -nooverlap
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
DESCRIPTION="Type-safe, multi-backend data serialization"
HOMEPAGE="https://www.yesodweb.com/book/persistent"
SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE=""
RDEPEND=">=dev-haskell/aeson-1.0:=[profile?]
dev-haskell/attoparsec:=[profile?]
dev-haskell/base64-bytestring:=[profile?]
>=dev-haskell/blaze-html-0.9:=[profile?]
>=dev-haskell/conduit-1.2.12:=[profile?]
>=dev-haskell/fast-logger-2.4:=[profile?]
>=dev-haskell/http-api-data-0.3:=[profile?]
>=dev-haskell/monad-logger-0.3.28:=[profile?]
dev-haskell/mtl:=[profile?]
>=dev-haskell/path-pieces-0.2:=[profile?]
>=dev-haskell/resource-pool-0.2.3:=[profile?]
>=dev-haskell/resourcet-1.1.10:=[profile?]
dev-haskell/scientific:=[profile?]
dev-haskell/silently:=[profile?]
>=dev-haskell/text-1.2:=[profile?]
dev-haskell/unliftio:=[profile?]
dev-haskell/unliftio-core:=[profile?]
dev-haskell/unordered-containers:=[profile?]
dev-haskell/vector:=[profile?]
>=dev-lang/ghc-8.0.1:=
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.24.0.0
test? ( >=dev-haskell/hspec-2.4 )
"
src_configure() {
haskell-cabal_src_configure \
--flag=-nooverlap
}