You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-haskell/postgresql-libpq/postgresql-libpq-0.9.4.2-r2...

40 lines
853 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
# ebuild generated by hackport 0.5.6.9999
#hackport: flags: -use-pkg-config
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
DESCRIPTION="low-level binding to libpq"
HOMEPAGE="https://github.com/phadej/postgresql-libpq"
SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE=""
RDEPEND=">=dev-db/postgresql-7:*
>=dev-lang/ghc-7.4.1:=
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.10 <dev-haskell/cabal-3.3
"
src_prepare() {
default
cabal_chdeps \
'base >=4.3 && <4.13' 'base >=4.3' \
'Cabal >= 1.10 && <2.5' 'Cabal >= 1.10 && <3.3'
}
src_configure() {
haskell-cabal_src_configure \
--flag=-use-pkg-config
}