You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-haskell/regex-compat/regex-compat-0.95.2.0.ebuild

41 lines
933 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
# ebuild generated by hackport 0.6.1
#hackport: flags: +newbase,+splitbase
CABAL_FEATURES="lib profile haddock hoogle hscolour"
inherit haskell-cabal
DESCRIPTION="Replaces/Enhances Text.Regex"
HOMEPAGE="https://hackage.haskell.org/package/regex-compat"
SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE=""
RDEPEND=">=dev-haskell/regex-base-0.94:=[profile?] <dev-haskell/regex-base-0.95:=[profile?]
>=dev-haskell/regex-posix-0.96:=[profile?] <dev-haskell/regex-posix-0.97:=[profile?]
>=dev-lang/ghc-7.4.1:=
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.12
"
src_prepare() {
default
cabal_chdeps \
'base >= 4.3 && < 4.14' 'base >= 4.3'
}
src_configure() {
haskell-cabal_src_configure \
--flag=newbase \
--flag=splitbase
}