You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-haskell/regex-tdfa/regex-tdfa-1.3.1.0.ebuild

48 lines
1.3 KiB

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
# ebuild generated by hackport 0.6.2.9999
#hackport: flags: +base4,-devel,+force-o2
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
DESCRIPTION="Replaces/Enhances Text.Regex"
HOMEPAGE="https://hackage.haskell.org/package/regex-tdfa"
SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE=""
RDEPEND=">=dev-haskell/fail-4.9:=[profile?] <dev-haskell/fail-4.10:=[profile?]
>=dev-haskell/mtl-2.1.3:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
>=dev-haskell/parsec-3.1:=[profile?] <dev-haskell/parsec-3.2:=[profile?]
>=dev-haskell/regex-base-0.94:=[profile?] <dev-haskell/regex-base-0.95:=[profile?]
>=dev-haskell/text-1.2.3:=[profile?] <dev-haskell/text-1.3:=[profile?]
>=dev-lang/ghc-7.4.1:=
>=dev-haskell/semigroups-0.18:=[profile?] <dev-haskell/semigroups-0.20:=[profile?]
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.12
test? ( dev-haskell/semigroups
>=dev-haskell/utf8-string-1.0.1 <dev-haskell/utf8-string-1.1 )
"
src_prepare() {
default
cabal_chdeps \
'base >= 4.5 && < 4.14' 'base >= 4.5'
}
src_configure() {
haskell-cabal_src_configure \
--flag=base4 \
--flag=-devel \
--flag=force-o2
}