You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-haskell/scientific/scientific-0.3.6.2.ebuild

37 lines
1003 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
# ebuild generated by hackport 0.5.6.9999
#hackport: flags: -integer-simple
CABAL_FEATURES="lib profile haddock hoogle hscolour" # disable test-suite: circular depends
inherit haskell-cabal
DESCRIPTION="Numbers represented using scientific notation"
HOMEPAGE="https://github.com/basvandijk/scientific"
SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE=""
RESTRICT=test # circular depends
RDEPEND=">=dev-haskell/bytestring-builder-0.10.4:=[profile?] <dev-haskell/bytestring-builder-0.11:=[profile?]
>=dev-haskell/hashable-1.1.2:=[profile?]
>=dev-haskell/integer-logarithms-1:=[profile?]
>=dev-haskell/primitive-0.1:=[profile?]
>=dev-haskell/text-0.8:=[profile?]
>=dev-lang/ghc-7.4.1:=
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.10
"
src_configure() {
haskell-cabal_src_configure \
--flags=-integer-simple
}