You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-haskell/semigroupoid-extras/semigroupoid-extras-5.ebuild

32 lines
835 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
# ebuild generated by hackport 0.6.6.9999
CABAL_FEATURES="lib profile haddock hoogle hscolour"
inherit haskell-cabal
DESCRIPTION="Semigroupoids that depend on PolyKinds"
HOMEPAGE="https://github.com/ekmett/semigroupoid-extras"
SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE="+profunctors"
RDEPEND=">=dev-haskell/semigroupoids-5:=[profile?] <dev-haskell/semigroupoids-6:=[profile?]
>=dev-lang/ghc-7.6.2:=
profunctors? ( >=dev-haskell/profunctors-5:=[profile?] <dev-haskell/profunctors-6:=[profile?] )
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.16.0
"
src_configure() {
haskell-cabal_src_configure \
$(cabal_flag profunctors profunctors)
}