You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-haskell/shelly/shelly-1.9.0.ebuild

46 lines
1.3 KiB

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
# ebuild generated by hackport 0.6.1.9999
#hackport: flags: build-examples:examples
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
DESCRIPTION="shell-like (systems) programming in Haskell"
HOMEPAGE="https://github.com/yesodweb/Shelly.hs"
SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE="examples lifted"
RDEPEND="dev-haskell/async:=[profile?]
dev-haskell/enclosed-exceptions:=[profile?]
>=dev-haskell/exceptions-0.6:=[profile?]
dev-haskell/lifted-async:=[profile?]
dev-haskell/lifted-base:=[profile?]
>=dev-haskell/monad-control-0.3.2:=[profile?] <dev-haskell/monad-control-1.1:=[profile?]
>=dev-haskell/mtl-2:=[profile?]
dev-haskell/text:=[profile?]
dev-haskell/transformers-base:=[profile?]
<dev-haskell/unix-compat-0.6:=[profile?]
>=dev-lang/ghc-8.0.2:=
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.24.2.0
test? ( >=dev-haskell/hspec-2.0
dev-haskell/hspec-contrib
>=dev-haskell/hunit-1.2
>=dev-haskell/text-0.11 )
"
src_configure() {
haskell-cabal_src_configure \
$(cabal_flag examples build-examples) \
$(cabal_flag lifted lifted)
}