You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-haskell/uuid-types/uuid-types-1.0.3-r1.ebuild

46 lines
1.3 KiB

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
# ebuild generated by hackport 0.4.7.9999
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
DESCRIPTION="Type definitions for Universally Unique Identifiers"
HOMEPAGE="https://github.com/aslatter/uuid"
SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE=""
RDEPEND=">=dev-haskell/binary-0.4:=[profile?] <dev-haskell/binary-0.9:=[profile?]
>=dev-haskell/random-1.0.1:=[profile?] <dev-haskell/random-1.3:=[profile?]
>=dev-haskell/text-1:=[profile?] <dev-haskell/text-1.3:=[profile?]
>=dev-lang/ghc-7.4.1:=
>=dev-haskell/hashable-1.1.1.0:=[profile?] <dev-haskell/hashable-1.3:=[profile?]
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.8
test? ( >=dev-haskell/hunit-1.2
>=dev-haskell/quickcheck-2.4
>=dev-haskell/tasty-0.10
>=dev-haskell/tasty-hunit-0.9
>=dev-haskell/tasty-quickcheck-0.8 )
"
src_prepare() {
default
cabal_chdeps \
'QuickCheck >=2.4 && < 2.9' 'QuickCheck >=2.4' \
'HUnit >=1.2 && < 1.4' 'HUnit >=1.2' \
'tasty >= 0.10 && < 0.12' 'tasty >= 0.10' \
'tasty-hunit == 0.9.*' 'tasty-hunit >= 0.9' \
'tasty-quickcheck == 0.8.*' 'tasty-quickcheck >= 0.8' \
'random >= 1.0.1 && < 1.2' 'random >= 1.0.1'
}