You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-haskell/zlib-enum/zlib-enum-0.2.3.1-r1.ebuild

41 lines
1016 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
# ebuild generated by hackport 0.6.6.9999
#hackport: flags: -test
CABAL_FEATURES="lib profile haddock hoogle hscolour"
inherit haskell-cabal
DESCRIPTION="Enumerator interface for zlib compression"
HOMEPAGE="https://github.com/maltem/zlib-enum"
SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE=""
RDEPEND=">=dev-haskell/enumerator-0.4:=[profile?] <dev-haskell/enumerator-0.5:=[profile?]
>=dev-haskell/zlib-bindings-0.1:=[profile?] <dev-haskell/zlib-bindings-0.2:=[profile?]
>=dev-lang/ghc-7.8.2:=
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.18.1.3
"
src_prepare() {
default
cabal_chdeps \
'transformers >= 0.2 && < 0.5' 'transformers >= 0.2' \
'transformers >= 0.2 && < 0.5' 'transformers >= 0.2'
}
src_configure() {
haskell-cabal_src_configure \
--flag=-test
}