You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-java/ant-apache-bsf/ant-apache-bsf-1.10.9.ebuild

24 lines
662 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
ANT_TASK_JDKVER=1.8
ANT_TASK_JREVER=1.8
ANT_TASK_DEPNAME="bsf-2.3"
inherit ant-tasks
KEYWORDS="amd64 ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="python javascript tcl"
DEPEND=">=dev-java/bsf-2.4.0-r1:2.3[python?,javascript?,tcl?]"
RDEPEND="${DEPEND}"
pkg_postinst() {
if [[ -z "${REPLACING_VERSIONS}" ]]; then
elog "Also, >=dev-java/bsf-2.4.0-r1 adds optional support for groovy,"
elog "ruby and beanshell. See its postinst elog messages for instructions."
fi
}