You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-java/cdi-api/cdi-api-1.2.ebuild

37 lines
792 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
JAVA_PKG_IUSE="doc source"
inherit java-pkg-2 java-pkg-simple
DESCRIPTION="Contexts and Dependency Injection for the Java EE platform"
HOMEPAGE="http://www.cdi-spec.org/"
SRC_URI="https://repo1.maven.org/maven2/javax/enterprise/${PN}/${PV}/${P}-sources.jar"
LICENSE="Apache-2.0"
SLOT="1.2"
KEYWORDS="amd64 x86"
IUSE=""
CDEPEND="dev-java/javax-inject:0
dev-java/glassfish-interceptor-api:0
dev-java/tomcat-servlet-api:3.0"
RDEPEND=">=virtual/jre-1.6
${CDEPEND}"
DEPEND=">=virtual/jdk-1.6
app-arch/unzip
${CDEPEND}"
JAVA_SRC_DIR="src"
JAVA_GENTOO_CLASSPATH="javax-inject,tomcat-servlet-api-3.0,glassfish-interceptor-api"
java_prepare() {
mkdir src || die
mv * src
}