You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-java/constantine/constantine-0.7-r1.ebuild

39 lines
856 B

# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
JAVA_PKG_IUSE="source test"
inherit java-pkg-2 java-ant-2
DESCRIPTION="Provides Java values for common platform C constants"
HOMEPAGE="https://github.com/wmeissner/jnr-constants"
SRC_URI="mirror://gentoo/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
IUSE=""
RDEPEND=">=virtual/jre-1.6"
DEPEND=">=virtual/jdk-1.6
test? (
dev-java/ant-junit:0
)"
src_compile() {
# ecj doesn't like some cast for some reason
java-pkg_force-compiler javac
java-pkg-2_src_compile
}
src_test() {
ANT_TASKS="ant-junit4" eant test -Dlibs.junit_4.classpath="$(java-pkg_getjars --with-dependencies junit-4)"
}
src_install() {
java-pkg_dojar dist/${PN}.jar
use source && java-pkg_dosrc src/*
}