You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-java/helpgui/helpgui-1.1-r2.ebuild

33 lines
694 B

# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
JAVA_PKG_IUSE="doc source"
inherit java-pkg-2 java-ant-2
DESCRIPTION="HelpGUI is a simple library which develop a help viewer component"
HOMEPAGE="http://helpgui.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}-src.jar"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
DEPEND=">=virtual/jdk-1.4
app-arch/unzip"
RDEPEND=">=virtual/jre-1.4"
EANT_BUILD_TARGET="helpgui_jar"
EANT_DOC_TARGET="javadocs"
src_install() {
java-pkg_newjar build/${P}.jar ${PN}.jar
dodoc README
use doc && java-pkg_dojavadoc build/docs/api
use source && java-pkg_dosrc src/*
}